Requirements



Introduction

This page documents all software/libraries you need to run KMyMoney as well as providing links to locate the needed software.


Operating System/Machine

KMyMoney is a KDE application and should therefore run on any machine that has a KDE desktop environment installed: GNU/Linux, xBSD...

KMyMoney is available for KDE3 and KDE4 environments.

Nevertheless, the following has to be considered:
 
KMyMoney >= 3.95 needs KDE 4.3 or above (if you get it working with 4.2 please let us know)
KMyMoney >= 4.6.90 needs KDE 4.4 or above
 
KMyMoney < 0.7 needs KDE 3.0 or above
KMyMoney >= 0.7 needs KDE 3.2 or above
KMyMoney >= 0.8 needs KDE 3.3 or above
KMyMoney >= 0.9 needs KDE 3.4 or above

Software

The only software needed are the development utilities that are usually installed by most distributions.


Required Libraries

This list shows the libraries that this program requires. They are group in three categories:

The following list contains the libraries required on top of the standard glibc, X, Qt, KDE etc. libraries. We assume those are present on todays distributions. If we are wrong in this assumption, please leave us a note at kmymoney-devel@kde.org with a short description of your environment and the missing library and we take into the list.